mrsolusi.com

Cara Membuat Bot Telegram Untuk Monitoring Status Access Point Hotspot

Posted on

Pengen Cepat Update Jika perangkat pada jaringan anda down?
Maka solusinya adalah membuat bot telegram dengan fitur Netwatch.
dimana Kalian akan Cepat mengetahui bahwa Accsess point tersebut down, maka kalian akan lebih duluan memperbaikinnya sebelom pelangga atau pengguna hotspot kalian komplain hahahah..

Oke lanjut ke Judul
“Cara Membuat Bot Telegram Untuk Monitoring Status Access Point Hotspot”

Hal yang wajib kalian miliki adalah Akun telegram & Jaringan Hotspot.,

Jika kalian sudah memiliki akun tersebut, maka kalian boleh lanjut membaca dan mencoba trick ini.

namun jika belom ada dari ke 2 itu
sebaikkan pergi dari sini ,..

Pertama Kita buat dahulu BOT telegram melalui father bot
cari di pencariian telegram dengan keyword @BotFather

Kalian buat bot kalian, untuk caranya harusnya tidak usah di buat tutorialnya.. kenapa?
karena ketika kalian pejet start maka kalian sudah di arahin duluan … Okey?

Okey lanjut  pada tahap pengambilan bot id dan chat id

saat kalian berhasil buat akun bot
maka akan muncul  informasi Token HTTP API, catat dan simpanlah informasi Token yang nanti akan kita gunakan di langkah selanjutnya.

Okey sampai sini kalian sudah mendapatkan id bot
sekarang giliran mencari id kalin

caranya ada 2 cara
1 memakai bot nama Bot nya @get_id_bot
1 lagi memakai URL https://api.telegram.org/(Token Anda)/getUpdates lalu akan muncul informasi chat id

Oke Di sisi bot telegram sudah oke

sekrang saatnya masuk ke mikrotik ke tool >> netwatch
Kalian Add ip yang mau di monitoring dalam keadaan up atau down

set ip berapa yang mau di monitor , dan intervalnya berapa menit sekali miktoritknya check
dan masuk ke tap down dan up
pastekan scrip ini ke tap down

:local hh $host
:local bot "904712554:AAXXXX"
:local chat "550XX"
:local datetime "Tanggal: $[/system clock get date] %0A Jam: $[/system clock get time]"
:local com [/tool netwatch get value-name=comment [find host=$hh] comment];
/tool fetch url="https://api.telegram.org/bot$bot/sendmessage\?chat_id=$chat&text=$datetime %0ARouter: $com $hh OFF \E2\9D\8C " keep-result=no


dan Scrip ini di menu UP
:local hh $host
:local bot "904712554:AXXX"
:local chat "59XXX"
:local datetime "Tanggal: $[/system clock get date] %0A Jam: $[/system clock get time]"
/tool fetch url="https://api.telegram.org/bot$bot/sendmessage\?chat_id=$chat&text=$datetime %0ARouter: $hh ON \E2\9C\85" keep-result=no


keterangan

local bot di isi token bot
local chat di isi chat id

Hasil

1421 Views

One thought on “Cara Membuat Bot Telegram Untuk Monitoring Status Access Point Hotspot

Leave a Reply

Your email address will not be published. Required fields are marked *